琳琅综合社区 - 为梦想而战

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 251|回复: 0

利用易语言制作增删改查功能

[复制链接]

UID
2
松籽
1174
松鼠
3121
松叶
222
松果
0
勋章币
0
魅力值
0
在线时间
388 小时
注册时间
2016-12-25
发表于 2018-8-27 11:02:52 | 显示全部楼层 |阅读模式
首先要想写这个功能必须要回sql的一些语句才能写
接下来看图

这是我写的关于sql的增删改查功能 喜欢的支持

利用编辑框组件和按钮写的
  1. .版本 2
  2. .支持库 mysql
  3. .支持库 spec

  4. .程序集 窗口程序集_启动窗口
  5. .程序集变量 是否成功, 逻辑型
  6. .程序集变量 mysql句柄, 整数型

  7. .子程序 __启动窗口_创建完毕

  8. ' 首先连接数据库
  9. mysql句柄 = 连接MySql (“localhost”, “root”, “root”, “school”, 3306)

  10. .子程序 _按钮1_被单击

  11. ' 查看是否连接成功
  12. 是否成功 = 执行SQL语句 (mysql句柄, “SELECT * from student”)
  13. 调试输出 (是否成功)

  14. .子程序 _按钮2_被单击

  15. ' 新增数据库
  16. 是否成功 = 增加记录 (mysql句柄, “student”, “s_name='” + 编辑框1.内容 + “'” + “,s_gender='” + 编辑框2.内容 + “'”)
  17. 调试输出 (是否成功)

  18. .子程序 _按钮3_被单击

  19. ' 修改数据库 数据
  20. 是否成功 = 执行SQL语句 (mysql句柄, “UPDATE student SET s_name='” + 编辑框4.内容 + “'WHERE s_id='” + 编辑框3.内容 + “'”)
  21. 调试输出 (是否成功)

  22. .子程序 _按钮4_被单击

  23. ' 删除数据库
  24. 是否成功 = 执行SQL语句 (mysql句柄, “DELETE from student WHERE s_id='” + 编辑框5.内容 + “'”)
  25. 调试输出 (是否成功)
复制代码


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
琳琅为天地而生,为梦想而战。www.98linlang.com
*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|琳琅综合社区 - 为梦想而战 ( 晋ICP备18002626号 )

GMT+8, 2018-11-19 11:59 , Processed in 0.205710 second(s), 43 queries , Gzip On.

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表